Geo-reference Map Generation

When using EFDC_Explorer and CVLGrid it is often useful to have a background map of the region displayed behind the model. This How-To guide describes the approach to develop these background maps for Lake Okeechobee, Florida. To create the background map in EE or CVLGrid the following tools are required:

Geo-reference Map Generation Process

Using Google Earth

The software allows us to generate images and coordinates of the determined areas.

Generally, an image will be determined by two coordinates:

  • Upper Left (UL)/Lower Right (LR) corners, or
  • Lower Left (LL) /Upper Right (UR)

Example: generating a geo-referenced map for Lake Okeechobee, Florida, United States. This model and background map are available from the EEMS website

Step 1: Determine Magnetic Declination

  • The purpose of determining the Magnetic Declination is to identify true north for the site. Note that a positive declination is east, while a negative declination is west.
  • Run Google Earth
  • Type Lake Okeechobee in the search box then select the "Enter" key on the keyboard.
  • On the toolbar of Google Earth, left mouse click on Tools > Options > Apply > OKFigure 1 and Figure 2 show this process.
  • Add a temporary place-mark (see Figure 3) so we can get the coordinate of the place-mark
  • Open USGS Web Calculator: http://ngdc.noaa.gov/geomag-web/ ( see Figure 4).
  • Copy and paste coordinates of the place-mark into the USGS web calculator. Note that select S/N and W/E accurately (see Figure 5 ) then left mouse click on Calculate button.
  • The result of Magnetic Declination is displayed in Figure 6.
  • Go back the Google Earth, enter the Magnetic Declination 6.26oW (W means that the declination here is negative) on the heading of the place-mark. (see Figure 7) then LMC the OK button. We will see that the background image on Google Earth will rotate from the west to the east with an angle of 6.26o.
  • After the background image points to true north correctly we can delete the temporary place-mark by RMC on place-mark then select Delete option.

Figure 1.  Options feature in Tool menu of Google Earth.

Figure 2.  Setup Google Earth Options.

Figure 3.  Add a temporary place-mark on Lake Okeechobee.

Figure 4.  USGS web calculator interface.

Figure 5.  Entering the coordinates of the place-mark to USGS web calculator.

Figure 6.  Declination of the place-mark.

Figure 7.  Entering declination of the place-mark into Heading field.


Step 2: Determine Upper Left (UL) and Lower Right (LR) Coordinates


  • On the toolbar of Google Earth, LMC on Tools > Options > Apply > OK. (See Figure 8).
  •  Add place-mark as names UL and LR


UL

LR

Easting  467419.45 m E

Northing  3009561.68 m N


Easting  563219.52 m E

Northing  2951517.39 m N

Figure 8.  Setup UTM option on Google Earth.


Figure 9.  Define UL coordinates.

Figure 10.  Define LR coordinates.


Step 3: Save image for UL-LR Area

Figure 11.  UL and LR image saving.


  • Choose "Premium" resolution
    • Image resolution selection is optional. Only the professional version of Google Earth allows users to save the image with different resolutions. In this document, the highest resolution is recommended to be chosen.


Figure 12.  Choosing Premium resolution.

Using EE, CVLGrid and Global Mapper

Note that users can generate a geo-reference map in both EFDC_Explorer (EE) and CVLGid. The process for generating the map is the same in both tools.

 Option 1: Using EE

  • Click Tools in the toolbar and then select Image Georeferencing 

Figure 13.  Geo-Referencing tool in EFDC_Explorer.

  • Click Open button and browse to the image of Lake Okeechobee, which was generated by Google Earth and saved in JPEG format *.jpg.

Figure 14.  Load image.

  • Right mouse click on UL and then type the Easting coordinate into World X and Northing coordinate into World Y

Figure 15.  Declare UL coordinates.

  • Click Add Point
  • Right mouse click on LR and then type the Easting coordinate into World X and Northing coordinate into World Y

Figure 16.  Declare LR coordinates.

  • Click Save button and enter the name and folder location for the geo-reference file then click Save button.

Figure 17.  Save the geo-reference file.

Option 2: Using CVLGrid

  • Click open CVLGrid
  • Click on Setup in the Geo-referencing tool

Figure 18. Geo-Referencing tool in CVLGrid.


  • Load the bitmap file (browse to the image of Lake Okeechobee, which was generated by Google Earth). The bitmap file is the image file which is called by CVLGrid. The image generated by Google Earth is a JPEG image (*.jpg), so the bitmap file to be loaded is the JPEG image.

Figure 19.  Load bitmap file.


  • Right mouse click on UL then choose Point 1
  • Type the Easting coordinate into X and Northing coordinate into Y

Figure 20.  Declare UL coordinates.


  • Right mouse click on LR then choose Point 2
  • Type the Easting coordinate into X and Northing coordinate into Y

Figure 21.  Declare LR coordinates.


  • After typing coordinates of UL and LR click Update button
  • File > Save Geo-reference File (enter the name and folder location for the geo-reference file) then click Save button.

Figure 22.  Save the geo-reference file.


Figure 23.  Naming and storing geo-reference files.


  • The geo-reference file named Okeechobee Lake.geo is now generated and can be loaded at any time.

Figure 24.  Geo-reference file loaded.

Option 3: Using Global Mapper

Global Mapper® is a GIS software of Blue Marble Geographics® software company. The geo-referenced map generated from this tool can be opened in EEMS as an offline background map in the 2DH View. This section will describe how to generate the geo-referenced map from the Global Mapper.

  • From the model loaded in EE, we export model grid outline in shapefile format. This shapefile will define the region of the map in Global Mapper.
  • Open Global Mapper, then click Open Your Own Data Files (Figure 25)
  • Browse to the shapefile to open it (Figure 26 and 27)
  • Click Online Download Data button, then in the IMAGERY, select World Imagery then click OK button (Figure 28 and 29)

Figure 25.  Open Global Mapper.

Figure 26.  Open Model Outline (shapefile).

Figure 27.  Model Outline (shapefile) Loaded.

Figure 28.  Open Online World Imagery Map (1).

Figure 29.  Open Online World Imagery Map (2).

  • Click on the Open Control Center, the Overlay Control Center form will be shown, uncheck on model_outline.shp layer then click Close button (Figure 30)

Figure 30.  Show off the shapefile layer.

  • Click File menu, then select Export Raster/Image Format (Figure 30)

Figure 30.  Export Raster/Image Format.

  • Select JPG format then click OK button (Figure 31)

Figure 31.  Export Raster/Image Format.

  • From the JPG Export Options form, in the General tab, we define to enter values for X-axis and Y-axis of the Sampling Spacing. The values entered here will define the resolution of the JPG file, the smaller values the higher resolution. Next, check on Generate World File option. Selecting this option will generate a *.jgw file accompany with *.jpg file (Figure 32).

Figure 32.  Define Resolution of Exporting Image (General tab).

  • Next, in the Export Bounds tab, click on Draw a Box button to define image area to export (Figure 33). We start drawing a rectangle (yellow highlighted) then click OK button (Figure 34). Then click OK button in the JPG Export Options form.

Figure 33.  Define Exporting Bounds.

Figure 34.  Drawing an Image Area to Export.

  • The Save As form will be displayed, we define the folder which the image will be exported to and enter a file name then click Save button (Figure 35).

Figure 35.  Enter a Filename to Export.

  • After the exporting process completed, we can see that there are two types of files in the folder (*.jpw and *.jpg) as shown in Figure 36.

Figure 36.  Image Exported Complete.

  • The exported image can be opened in the 2DH View of the EE as shown in Figure 36 and 37.

Figure 36.  Open the Exported Image in the 2DH View of the EE.

Figure 37.  Offline Geo-referenced Map Loaded in the 2DH View of the EE.